Unsupported major.minor version 51.0解决办法

作者:xcbeyond
疯狂源自梦想,技术成就辉煌!微信公众号:《程序猿技术大咖》号主,专注后端开发多年,拥有丰富的研发经验,乐于技术输出、分享,现阶段从事微服务架构项目的研发工作,涉及架构设计、技术选型、业务研发等工作。对于Java、微服务、数据库、Docker有深入了解,并有大量的调优经验。












因为需要验证个东西,所以今天在服务器上面,修改了应用启动时的JAVA_HOME,变为jdk1.6,服务启动时,发现在解析Java类时报“Unsupported major.minor version 51.0”。将jdk换回1.7,就没不会报错。经分析发现,是由于编译程序时使用的jdk版本为1.7,而现在修改为1.6了,不同JDK版本而导致的。



切记,在项目中一定保证编译和运行使用的JDK一致!


总结:不同的JDK版本使用的major.minor不同,所以会导致这个错误。在项目中要使用当前电脑配置的JDK版本,切忌张冠李戴。